OV Recorder Downloaded No Connection BR2 Camera


#1

Downloaded and activated OV Rec. BR2 Set up with multudpsink. Data set to retrieve BR2. Video in set to BR2 Camera showing Br2.sdp. Go to preview video and nothing. Tried to open BR2.sdp in VLC Media Player and nothing. Need help soonest



image


#2

Hello,

This is a Bluerobotics issue which has been addressed here: https://discuss.bluerobotics.com/t/get-video-in-videolan/1884/37

We also did a video of how to connect a second stream here: https://youtu.be/L0hE_dGz0Yg

What is typed in gstreamer option has to be identical to this:

! h264parse
! queue
! rtph264pay config-interval=10 pt=96
! multiudpsink clients=192.168.2.1:5600,192.168.2.1:2000

do not add a line after multiudpsink.

Regards,
Delta ROV


#3

Put gstreamer to default and re-entered multiudpsink exactly again, no spaces no extra lines and still NO Video.

Also, no video when opening BR2.sdp with VLC?


#4

Hello,

we cannot help unless you provide more details about your setup including screenshots.

Regards,
E.


#5

Make sure you are running the software as administrator.

Also check that your firewall is not blocking ov-rec


#6

Firewall and Administrator Permissions checked days ago following your videos.

I don’t know what else you want from me on pics of setup.

OV worked on this computer a year ago. It’s dedicated ROV computer with no BS downloaded to it. I’ve uninstalled and reinstalled your software twice. I found the BR2 Data and even tried to run Python script and nothing. Completely rebooted and tried again.

I don’t understand why VLC won’t even run from BR2.sdp file.

I just flew out of town for a weeks worth of training and won’t have access to my system at all.

Doug


#7

Hello,

being that the video will not show up in VLC then it is not a problem from Oceanvault. In fact, this is the only installation with this problem.

There are 2 options:

  1. Contact Bluerobotics for further support
  2. Completely erase your machine and reinstall windows 10.

Cheers,
E.


#8

What is black button right of Preview? For whatever reason I finally started getting camera if after hitting preview, it would flash and go back to black and if I hit black button on right I got camera image.

Now I don’t have any data for heading, depth etc.

Your YouTube video is only for old set up using Python.

I now have most up to date ArduSub Stable version.

I have installed and activated the Data Server to see what I can see there. Unfortunately, I am unable to find any instructions how to use it. Please Help.

Unable to find anything on youtube
Doug


#9

Tried to run on my other ROV with latest ArduSub and Companion 0.0.26 and this one shows error in Data box.

Doug


#10

This is to turn on picture in picture. (PIP)

Preview turns on/off video feed specified in “Video In” Tab

The PIP button turns on the video feed specified in “PIP” tab

If #HEADING is specified, you need to uncheck “Parse”
You must also turn ON “Use Data”

Put a timeout value of 1000 and a comma as a separator.

If still no data, check if you have any data coming in; Turn on chrome, go to http://192.168.2.2:4777/mavlink/

I uploaded this video, more to come.


#11

Shows 0’s on OL now. Still no data.

http://192.168.2.2:4777/mavlink/ returns “no valid path” on Edge, Explorer and Chrome.


#12

Data Server also shows" no valid path"


#13

My other ROV still showing error in Data and adjusting settings per instructions.


#14

Update Trouble Shooting

With Companion 0.0.20 Data String in OV Rec no error but DS does not connect to Data “No,valid,path”.

With Companion 0.0.26 OV-Rec Data Error Msg but DS connects to data.

Neither displays data in OV-Rec OL


#15

Please contact Bluerobotics to get this sorted out. We can’t get this sorted until data show on this address.

Make sure both ROVs have same version of companion and ardusub.


#16

FYI the last update was with same ROV with swap of SD card, on with companion 20 and other with companion 26.


#17

we are presently using companion 024. We will upgrade to 026 and see if it works


#18

Hello,

we are able to reproduce the error with version 024 and 026.

We will amend our code and revert with a solution within 7 days.

In the meantime we suggest reverting back to 020.

Many thanks for bringing this to our attention.