Throttle sensor HCU

We have a problem with our HCU. The throttle button doesn’t respond to our inputs:

When we use it with our BlueROV2, the controller gives full throttle to the ROV. I checked it in the HCU tester and the channel that corresponds with this button stays on full throttle. I can move the button, but nothing happens. I tried re-loading the BlueROV2 configuration, the problem remains. I also tried it on both our ROV’s but to no effect. When I use a different remote with the ROV it works normally. Can anyone tell me if this is a software or hardware related issue?


This is definitely not a software issue. Either the connector or wire got dislodged or the apem sensor had gone bad.

Please open the HCU and take pictures.

Check the connector from the single axis joystick and see if the connector is not fully inserted.

Check continuity between the pin on the PCB and the side of the wiring harness that connects to the joystick.

Please send us pictures and test results so we can better assist you.

Delta ROV


I have opened up the HCU and checked the connections, all looks right. Disconnecting and reconnecting the connector seemed to have resolved the issue, the throttle button is working again. Will monitor the functioning of the controller, let’s hope this was just a simple fix :slight_smile: Below pictures of the inside for your approval.

Sincerely, Frank

Hello, glad it was a simple solution.

The inside looks good.

Let us know if you have any further issues.