Depth Hold not working with HCU

This was not working on last job I used it for in May. I opened up and confirmed the button is making connection to board inside when pushed. It is good so either board or software problem. I downloaded the HCU software / instructions and have “HCU connected to setup software” but can do nothing from there. Tried read program and nothing. Tried program and nothing. tried Reboot and it does so I start all over again.

Note that instructions show a Joystick Mode of Crawler, Normal, Reverse to select but my controller does not have this modes. I tried downloading the Rev1.1.1 and it has same Joystick Modes.

Does my controller need different software?

Please advise soonest.



Something happened and now the HCU no longer functions anything for BR2

After changing windows scale I can see Load button on config software. Unfortunately the saved configs I have are not matched to my current BR2 Button assignments. Is the BR2.HCU file on web site the basic config set up I could use to get going again?

Good News is I have Depth Hold working. Bad News is HCU has no ability to access Shift functions without holding an assigned shift button. This only works if I use a function and the non-shift corresponding number is disabled.

I have spent probably 10 hours working through crashes, lessons learned on sequence of operations to make sure settings are taken, file saved not to file I select and on and on. I have tried shift btn at 0, 34, 6 etc. I believe supposed to be zero. I have hit program in Shift mode, normal mode, no mode selected. No matter what I do the buttons 17 through 33 will only actuate the same number in QGround Joystick buttons screen.

See last set up in pic.

Please help soonest


What did you do to fix your depth hold issue?

I have uploaded the latest manual and BR2-Heavy.hcu file:

As per this Manual, 0 means its disabled. Also, you cannot assign the same button output to more than one physical button. I see that Gain UP and DN share the same number as User1 and 2, you need to change that.

Also QGC is zero based so button 0 is actually button 1 seen by windows. You can confirm that by running joy.cpl to test the joystick. It makes sense for the programmer but not so much for the end user. They should change it.

Looking at your QGC config, shift is set to 6 which means its actually windows button 7 so your shift button number should be button 7 in the HCU Config software as well.

You have the first revision of the HCU which does not include the 3 modes or the additional side buttons. Apart from that, its the same. The software is slightly different though. I have uploaded version 1.0.0 which should work for you.


Unknown what fixed depth other than physically unplugging and plugging.

With shift mode on and shift button other than 0 manual says will execute shift function of the button number -16. This did not happen under any circumstance for me when set to 6 or 34. I assume can be any number from 1 to 64 as long as not shared with another HCU assigned button.

My shift button is the Input button which indeed is set to 7 as you suggest. If used in two button operation what do I assign the button number for shift function to correspond with say button 2 in QGC?

After using the HCU software you provided the shift function worked showing both shift button and number of corresponding function number -16 as it’s supposed to. Never happened with previous.

As to the Gain button DN and UP 11,12 being same as user buttons I first tried setting user buttons to 0. Seems to me that the Gain button simply toggles modes and does nothing for actuating buttons 11 or 12. There for set gain UP and DN to 0 as they seem useless and put open close buttons to control gain for now. Maybe you can explain how DN UP works with Gain BTN.

Maybe you can explain how DN UP works with Gain BTN.