Delta Hand Controller newton gripper jog function

Hello, I’m Julien and I am working on using the Delta HCU for my Heavy Configuration BROV2. I have a newton ripper implemented on my ROV and wanted it to make it work with the jog function it had previously. While I was able to make it open and close with the correct button assignment of my choosing, it only fully opens/closes instead of jogging it (open/close when holding button and stopping when I let go of the button). When using previous controllers they did that and I would like to keep that usability. On QGroundControl, I have my button assignment on the min/max momentary that worked with previous controllers:

To try and fix this problem I tried changing the button assignment on QGC to all the possible servo buttons like just min/max, toggle, increase/decrease. Within the HCU program configuration I also tried adjusting the trigger time in hopes that changes the time the button is pressed for but to no avail it did not change how the gripper fully opened/closed. I was curious if the buttons on the HCU can’t handle jog and that I’d have to assign the gripper to one of the dials instead. But then I did try that it resulted in same problem. But just like how the camera will move and stop when you go in one direction or the other, I’d like something similar to that for the gripper.

One interesting thing I found to work is that I added an extra button assignment which was servo_n_center. Using that button, I was able to stop the gripper in its current position. So I have found a manual way to make it so it doesn’t always fully open/close, but that is an inefficient process of using an extra button to jog the gripper. Hopefully this helps bring perspective to what the problem is though.

I was hoping someone knows a way to properly implement the jog option for my gripper buttons.


Did you try moving the Servo_3_min_momentary to a button from 0 to 15?

Also, you could use our expanse PCB to control the gripper.

We don’t have any HCU on hand right now but we will test once we get some built in a couple of weeks.

Delta ROV

1 Like

I have had my gripper on the shift buttons so I believe it is assigned a button above 15. So you mean trying to assign it to one of the primary buttons without shift? Also by expanse PCB is that the expanse control system software you sell?


Yes, we believe this is caused by the automatic shift button so moving it to a primary should solve the issue.

You should have received an expanse PCB with the HCU and you can download it from our website at the following address: Dropbox - Expanse REV 2.1.0 - Simplify your life

Delta ROV

1 Like

Thank you for your help. Moving the gripper to the main button assignments did the trick. I just swapped the gripper and light buttons and reconfigured the HCU buttons through the program software. And now it is running perfectly with the right button assignments!