Apr15'09 Software Updates not Working?


#1

Hello!

I tried updating the Raspberry Pi Companion software and the Pixhawk Firmware to the ff:

as instructed in https://www.bluerobotics.com/learn/bluerov2-software-setup/.

I was able to upgrade the Companion Software but when I tried upgrading the Pixhawk Firmware, I encountered bootloader errors. So I manually connected Pixhawk to my laptop and updated through QGC. It was able to load the new firmware successfully. However, when I tried to connect it back to the Companion PC, it says Ardusub is “Not Found” even though the Pixhawk is connected. Then, I manually checked the logs in RasPi and encountered the errors attached.

Any idea what’s wrong or how to fix it?

Thanks!


#2

Hello,

I usually update via the web interface. I suggest you get in touch with Bluerobotics on this one as they are the software experts.

support@bluerobotics.com

Do keep us informed of your progress.

Cheers,
Etienne


#3

Hello!

I was able to solve the problem by manually installing the iso image of ArduSub in the Raspberry Pi. I guess something went wrong when I tried updating it using the web interface.